January 14, 2006

Traditionally cursed

I'm not superstitious, but once in awhile the coincidences do get to me. It was Friday the 13th, but I didn't let that stop me! I went to Akihabara, bought a GeForce 6600 video card made by Gigabyte along with 2 gigabytes of Buffalo RAM. I double-checked all the specs, cross-checked with the Buffalo reference book at the store, read the directions in all the manuals, then carefully installed the new components and fired it up.

I got an "Abnormal Fan condition" error, so I opened the case back up and looked around. Sure enough, a plug had come undone. Plugged it back in, put the case on, fired it up again, and had no further problems.

Took a little while to download the latest video driver, but I got it downloaded, updated it, and logged on to City of Villains. For forty-five minutes I had the most incredible gameplay experience of my online life. Fast, gorgeous graphics, incredible detail, and not a single stutter or skipped frame.

Then the power cut off without warning.

Reset the power breaker, fired it up again. Forty minutes later, it cut off again, and this time it refused to boot back up.

Did I install something wrong? Did I miss a connection? Did the short-lived fan error cause some deeper problem?

I don't know, and probably never will. Tomorrow I take the video card and memory chips back for testing, but I'm sure they'll be clean. Next week sometime I'll have to work through my wife (my Japanese ability is too poor to do it myself) to negotiate a test and possible repair session at Sony, or maybe not. I don't know.

Maybe it was just the traditional Friday the 13th curse come to haunt me.